Cloud Infrastructure: temporarily unavailable

Incident Report for UI Bakery

Resolved

Cloudflare is back to normal. UI Bakery is accessible now.
Posted Nov 18, 2025 - 12:15 UTC

Identified

Cloudflare Global Network is experiencing issues. Cloudflare is aware of, and investigating an issue which potentially impacts multiple customers across the globe.

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 11:50 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 11:44 UTC
This incident affected: Server Infrastructure (Backend) and Frontend (Workbench).